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100%(5)100% found this document useful (5 votes)9K viewsThe document provides a list of 54 questions that appear to be from a viva voce or oral examination for a Programming for Problem Solving lab course. The questions cover topics in C programm...Al-enhanced title and descriptionSaveSave 84661605 C Language Viva Questions For
Later100%100% found this document useful, undefined Ans- C is a high-level language and general-purpose structured programming language. 2. What is a compiler? Ans- Compile is a software program that transfer program developed in a high-level language into executable object code. 3. What is an algorithm? Ans- The approach or method that is
used to solve the problem is called an algorithm. 4. What is a c token and types of ¢ tokens? Ans- The smallest individual units are known as C tokens. C has six types of tokens Keywords, Constants, Identifiers, Strings, Operators and Special symbols. 5. How many Keywords (reserve word)are in C? Ans- There are 32 Keywords in the C language. 6.
What is an identifier? Ans- Identifiers are user-defined names given to variables, functions and arrays. 7. What are the Back Slash character constants or Escape sequence characters available in C? Ans- Back Slash character constant are \t, , \0. 8. What is a variable? Ans- Variables are user-defined names given to memory locations and are used to
store values. A variable may have different values at different times during program execution. 9. What are the Data Types present in C? Ans- Primary or Fundamental Data types (int, float, char), Derived Datatypes(arrays, pointers) and User-Defined data types(structures, unions, enum) 10. How to declare a variable? Ans- The syntax for declaring
variable isdata type variable name-1, variable name-2,....variable name-n; Example 1: int a, b; Example 2: float p,q; 11.What is meant by initialization and how do we initialize a variable? Ans- While declaring a variable assigning value is known as initialization. Variable can be initialized by using assignment operator (=). 12.How many types of
operators or there in C? Ans- C consist Arithmetic Operators (+, -, *, /,%), Relational Operators (=, !=), Logical Operators (&&, ||, !), Assignment Operators (=, +=, -=, *=, /=), Increment and Decrement Operators (++, -), Conditional Operator(?:), Bitwise Operators(, ~, &, |, ) and Special Operators (., ->, &, *, size of) 13. What is a Unary operator
and what are the unary operators present in C? Ans- An operator which takes only one operand is called a unary operator. C unary operators are Unary plus (+), Unary minus (-), Increment and Decrement operators (++,-), Address of operator (&), Value at operator (*), sizeof operator, ones complement operator (~) 14. What is the use of the modulus
(%) operator? Ans- The modulus operator produces the remainder of an integer division. It cannot be used on floating-point data 15. What is the use of printf and scanf functions in C? Ans-Values of variables and results of expressions can be displayed on the screen using printf functions. Values to variables can be accepted through the keyboard using
scanf function 16. Forms of IF statements? Ans- Simple IF statement, IF-ELSE statement, NESTED IF-ELSE statement and ELSE IF ladder 17. Forms of IF statements? Ans- Simple IF statement, IF-ELSE statement, NESTED IF-ELSE statement and ELSE IF ladder 18. What is a goto statement? Ans- GOTO is an unconditional branching statement
which transfers control to the specified label. 19. What is a loop? Ans- Loop is a sequence of statements that runs repeatedly. 20. What are loop control statements in C? Ans- While do-while and for. 21. What are sections present in for loop? Ans- Initialization section, conditional section and increment/decrement section. 22. What is the use of break
statements? Ans- The break statement is used to exit from the loop. 23. What is an array? Ans-The array is a collective name given to similar elements. 24. How can we initialize an array? Ans- The initializer for an array is a comma-separated list of constant expressions enclosed in braces ( { } ). The initializer is preceded by an equal sign ( = ). You do
not need to initialize all elements in an array. 25. What is the difference between normal variable and array variable? Ans- A variable can store only one value at a time whereas an array variable can store several value at a time. 26. What are the types of Arrays? Ans- A one-Dimensional array, Two-Dimensional array and Multi-Dimensional array 27.
What is a character array? Ans- An array which can store several characters is called character array 28. What is a function? Ans- The function is a self-contained block of the statement which is used to perform a certain task 29. What are the types of functions? Ans- C functions are divided into two categories user-defined function and built-in
functions 30. Which are called built-in functions? Ans- Printf, scanf, clrscr, gotoxy, string handling functions and file handling functions 31. What is a recursive function? Ans- A function calling itself is called function recursion 32. How to pass an array to a function? Ans- Arrays are passed to a function by sending its address 33. What is a pointer
variable? Ans- A pointer variable is a variable that can store the address of another variable 34. How can we store the address of a variable is a pointer? Ans- By using the address of the operator we can store the address of a variable in a pointer 35. How many bytes does a pointer variable occupies in memory? Ans- A pointer variable irrespective of
its type it occupies two bytes in memory 36. What are storage classes available in C? Ans- Auto, static, extern and register 37. What is a structure? Ans- The structure is user-defined data typed. The structure is a collective name given to dissimilar elements 38. How to excess structure members? Ans- Structure members can be accessed using the dot
operator 39) What are the differences between structures and arrays? Ans- Structures store dissimilar values whereas arrays stores similar values. One structure variable can be assigned to another structure variable whereas one array variable cannot be assigned to another array variable 40. What is the size of a structure? Ans- Sum of all the
members size is becomes structure size 41. What is a union? Ans- Union is a user-defined data type that can store a value of different data types 42. What are the types of files we can create using C? Ans-We can create text and binary files using C 43. What are the file-handling functions present in C? Ans- fopen, fclose, fgetc, fputc, fgets, fputs, fprintf,
fscanf, fread, fwrite, fseek 44. What are the file opening modes present in C? Ans-r, w, a, r+, w+, a+, rb, wb, rb+, wb+ 45. How to access structure members by their pointer? Ans- We can use structure members using arrow operator with its pointer 46. What is the difference between normal variable and array variable? Ans- A variable can store only
one value at a time whereas an array variable can store several value at a time. 47. How to declare a variable? Ans- The syntax for declaring the variable is Datatype variable name-1,variable name-2...variable name-n We designed Top 100 MS-Word MCQ to help every professional and student. Practice these Top 100 MS-Word MCQ to test and
enhance your knowledge in ... We designed Top 100 MS-Excel MCQ to help every professional and student. Practice these Top 100 MS-Excel MCQ to test and enhance your knowledge in ... If you are preparing for a C programming viva or interview, then you have reached the right place. In this article, a list of frequently asked C programming viva or
interview questions and answers are given below. You will also get a mix of Basic to Advanced C programming viva or interview questions in this article. And before going ahead, if you want to know more about C programming, check out Introduction to C now? C Programming Viva Questions Answer Download (PDF) C Programming Viva Questions
Answers Part-1 Compiler is a program that converts human readable code (source code) into machine readable code, this process is called compilation. Interpreter converts human readable code (source code) into intermediate code and then this intermediate code is executed line by line. Assembler is a program that converts assembly level language
(low level language) into machine level language. Protocol is nothing but a set of rules to be followed by a programmer. IDE is nothing but integrated development environment. IDE is a tool that provides user to create, compile and execute C program. For example: Turbo C++, DevC++. These provide integrated development environment. In C
instructions are the statements which tells computer to perform the specific task. C is a high level programming language. It is used to develop system software and application software. C language has been developed using assembly language. Text file contain data that can be easily understood by human. It includes letters, numbers and other
characters. On the other hand, binary files contain 1s and Os that only computers can interpret. Yes, C language is structured language. An algorithm refers to the step by step instructions written to solve any problem. A flowchart is a diagrammatic or symbolic representation of an algorithm. It uses various symbols to represent the operations to be
performed. Library functions are predefined functions and stored in .lib files. A computer program is a collection of the instructions necessary to solve a specific problem. Compilation process translates source code into binary language. This binary language code is known as object code. This code contains object code and definition of predefined
function from library. This code is written in binary language. Void is an empty data type that has no value. We use void data type in functions when we don’t want to return any value to the calling functions. Header files contain declaration of predefined functions. We can use any number of header files in our program as per the requirement of
predefined functions. Some header files are: stdio.h, conio.h, math.h, stdlib.h, string.h, graphics.h It is possible to create a new header file. Create a file with function prototypes that need to be used in the program. Include the file in the ‘#include’ section in its name. Comma operator can be used to separate two or more expression. The printf()
function is used to print the integer, character, float and string values on to the screen or console. It is a predefined function. The scanf() function is used to take input from the user or read some values from screen (or console). It is a predefined function. Console is known as output screen through which user interacts with the source code. It is a pre-
processor directive. It is used to include any header file in our program. More Topics Conclusion So just feel confident during your viva interview and wish you the best of luck for your viva or interview. I hope these C questions and answers will help you to crack your exam easily. We use words and characters to communicate with each other. There
is no way to handle this type of data on computers. When we enter data into a computer, the data is, converted to an electronic pulse. Then pulse is identified as a code, and the code is transformed into numeric form by ASCII. To understand the language of computers, one must know the What is number system in computer. Table of Content Number
System A number system describes how values are stored and retrieved from and entered into a computer’s memory. In computers, letters, numbers, and other special characters are stores in coded form. Commonly, we use a number system to store data. There are two types of number systems: Characteristics of Number System A number system’s
base determines how many digits or symbols are available. The first digit of any number system is zero (0). Numbers’ last digit is always equal to base minus (-) one (1). For example, in the decimal number system, the base is 10, whose minimum value is 0, and the maximum value is 9. Non-Positional Number System A symbol in a non-positional
numbering system has the same value regardless of where it appears. One way to find a number is to count up the symbols in a number system. There is a symbol I for a 1, II for a 2, III for a 3, etc. Positional Number System Each symbol in a number system represents a different value based on its position. The value of each digit depends on three
factors: Digit itself. Position of the digit in a number. The base of the number. A number base refers to the number of digits in the system. Decimal Number System In our daily lives, we use a decimal number system. The Decimal system has only ten symbols or digits 0 to 9, so the base is 10. It is also known as the base-ten number system. Towards
the left, successive positions represent units, tens, hundreds, thousands, etc. Each digit in a decimal number has different weights depending on its placement within that number. There is a place value and a face value associated with a number. The face value of a number is its digit, while the place value is its magnitude. Suppose 7896 is a number.
In this number, 8 has a face value of 8 and a place value of 100. Advantages Decimal numbers are easy to read, understand, and manipulate. Disadvantages Binary Number System Binary numbers consist of two digits, 0 and 1. A value of 0 is equal to zero and, a value of 1 is one. There can be no such thing as 2/3/4, etc. Binary numbers use base 2 as
their base. This system is easier to understand than any other number system since it has only two digits. A bit consists of a binary number and a digit. Advantages It is easy to implement. The logic is simple to follow. Disadvantages Due to their larger size, binary numbers take up more space. Octal Number System Eight digits make up an octal
number (0,1,2,3,4,5,6,7). There are only eight (8) digits in it. Thus, its base is 8. Three-bit octal numbers are also known as binary-coded octal numbers. It is easier to use octal arrays than binary arrays because octal numbers have fewer digits. Advantages Octal numbers are about a third the size of binary numbers since they have fewer digits.
Disadvantages Computers can’t understand octal numbers, so octal to binary converter is needed. Hexadecimal Number System There are 16 digits in hexadecimal. Ten of the digits have the same meanings as the decimal system; they are 0, 1, 2, 3, 4, 5, 6, 7, 8, 9. The remaining six digits are A10, B11, C12, D15 and, F16. Its base or radix is 16.
Advantages By using less memory, it can store more numbers. Hexadecimal is also used to represent addresses in computer memory. Due to the four bits per digit, hexadecimal can be used to encode large binary numbers. Disadvantages The process of reading or writing hexadecimal numbers can be a challenge for some people. Numbers in the
hexadecimal system are hard to multiply and divide. Conclusion You may also be interested in these topics: What is Macro in Excel? A macro is a way to automate repetitive or routine tasks. We can use an Excel Macro to record and playback our Excel steps as many times as we want. We can perform a Macro with just one keystroke or command. It is
a series of instructions that make up a Macro. Why we use Macro? It automates repetitive tasks to save time and reduce the risk of human error. In this article, we will learn how to use Macro in Excel. Table of Content How many ways we can create a Macro in Excel? There are two ways to create Macros: VBA Programming Language and Macro
Recorder A programmer who wants to create a Macro using VBA programming needs to have programming knowledge. It is not necessary to know the programming language to use the Macro Recorder tool. It is a built-in method in Excel. Where can we find Macro? There are two places, where we can find Macro: View Tab and Developer Tab Go to
View Tab -> Macros Group -> Macros -> then we can select our option. There are a few options or frequently used options in the View Tab. The Macro tool can be found on the Developer Tab, which is hidden by default, so the first step is to enable it. Go to File Menu -> Options -> Customized Ribbon -> Main Tabs -> Tick mark or check Developer ->
Ok View Record Macro Dialog Box Go to the Developer Tab -> Code Group -> Click Record Macro We will see the Record Macro Dialog box. OR Go to View Tab -> Macros Group -> Click Record Macro In any of these ways, we can go to the Record Macro Dialog box. Description of Record Macro Dialog Box Go to the Developer Tab -> Code Group ->
Click on Record Macro A Record Macro dialog box will appear. Macro Name We will need to give our Macro a name.There must be a letter at the beginning of the name.There must be no spaces in it.If you want to separate words, use an underscore (). Shortcut Key We can create a shortcut key for this. Whenever we want to use shortcut keys,
remember the syntax. This is an optional step. Stored Macro In There are several ways to save Macros when creating them: This Workbook The Macro will only be available in the spreadsheet in which it is created. Personal Macro Workbook All spreadsheets will have access to the Macro. New Workbook A Macro will only work in spreadsheets that
are newer than the previous one. Description If we would like to provide some descriptions, please do so. Click Ok. Macro will now record all of your actions. Macro Example Let’s say we have to prepare the same spreadsheet each month with the same formatting and formulas. In that case, we use Macro, because here we have repetitive work. Here
we will create a Macro using Macro Recorder Tool. Step 1: Go to the Developer Tab -> Click on Record Macro It will pop up a dialog box to record Macros. We enter a name for the Macro, assign it a shortcut key (optional), store it, and give it a description (optional). As soon as we click OK, the recording of our Macro will begin. To check whether that
recording is the start or not. On the lower left corner of the screen, we can see that the stop button is enabled. Step 2: In order to create our Macro, we need to follow the layout. When you have created the above layout, click on the Stop Recording option under Developer Tab -> Stop Recording. Step 3: Go to the sheet where we want that layout to
appear. Make sure you select the exact range when you recorded the Macro. We use Macros only on the cells we use for recording, and they do not work on the rest. Step 4: Go to Developer Tab -> Macros -> Select the macro that we created for that layout -> Click on the Run option. OR Go to View Tab -> Macros -> View Macros -> Choose the
macro that we created for that layout -> Click on Run option. Here is the layout. The following field contains random items. View Recorded Macro To view recorded Macro, then go to View Tab -> Macros -> View Macros. A Macro dialog box will appear. We can view all the Macros We have recorded. Here is a list of all recorded Macros. We can select
the Macro which we want to run. How to Run a Macro? To run a Macro, go to the Developer Tab -> Code Group -> Macros -> Select your Macro -> Click on Run option. We can run a Macro by pressing a key combination, or we can select the Macro from the Macro List and then select Run. Add a Button to Run Your Macro In Excel, we can create a
button that will run our Macro. Follow these steps to do so: Step 1: Go to Insert Tab -> Illustration Group -> Shapes -> Select any Shape. We will use a Rectangle: Rounded Coroners. OR We can also insert a button by going to the Developer Tab -> Insert -> Form Control -> Button (Control). Step 2: To edit the text, right click the Shape and choose
Edit Text. We can also give some formatting to the shape. Step 3: Right click on the Shape, then select Assign Macro. On the Assign Macro dialog box, click OK to assign the Macro. Step 4: Once you've clicked on Run, leave your cursor on the first recorded cell. That is the Date cell. We can now work with our macro layout. Make sure we selected the
right cell range that we used while creating Macro. In our example, we use the same range of cells as we use while creating it. The Macro will run whenever we select (by clicking) this Shape. Key Point to Remember while Recording Macro The Macros will only work on the cells we use during recording. They do not work on the remaining cells.Once
we have recorded the Macro, make sure we check it.Don’t use the undo button when recording a Macro. Conclusion Our Excel work are simplified by Macros because they automate most of our routine tasks. Throughout this article, we learned how to use Macros in Excel. With one click or keystroke, we can perform several parts of a task at once.
More Topics Share — copy and redistribute the material in any medium or format for any purpose, even commercially. Adapt — remix, transform, and build upon the material for any purpose, even commercially. The licensor cannot revoke these freedoms as long as you follow the license terms. Attribution — You must give appropriate credit , provide
a link to the license, and indicate if changes were made . You may do so in any reasonable manner, but not in any way that suggests the licensor endorses you or your use. ShareAlike — If you remix, transform, or build upon the material, you must distribute your contributions under the same license as the original. No additional restrictions — You
may not apply legal terms or technological measures that legally restrict others from doing anything the license permits. You do not have to comply with the license for elements of the material in the public domain or where your use is permitted by an applicable exception or limitation . No warranties are given. The license may not give you all of the
permissions necessary for your intended use. For example, other rights such as publicity, privacy, or moral rights may limit how you use the material. A: C programming is a high-level programming language used for developing software applications. A: C was developed by Dennis Ritchie at Bell Labs in the early 1970s. A: A compiler translates the
entire program into machine code before execution, while an interpreter translates and executes code line by line. A: A header file is a file containing declarations for functions and variables that can be used in other C files. A: A C program generally consists of a preprocessor directive, main function, and user-defined functions. A: The “return 0;”
statement in the main function indicates a successful program execution and is often used to signal that the program was completed without errors. A: Comments in C are used to add explanatory notes to the code for documentation purposes. They are ignored by the compiler and start with “//” for single-line comments or are enclosed between “/”
and “/” for multi-line comments. A: The sizeof operator is used to determine the size, in bytes, of a data type or a variable, which can be helpful for memory allocation and buffer management. A: Escape sequences are special character combinations that begin with a backslash “” and are used to represent characters that are difficult to include directly
in a string, such as newline (“”) or tab (“\t”). A: A variable is a named storage location in a program that can hold different values during its execution. It is declared with a name, has a data type, and can change its value. In Simple words, a variable is a container for storing data in a program. A constant is a value that does not change during program
execution. It can be either named (with a symbolic name) or literal (a specific value used directly in code). A: int, float, char, double. A: It depends on the platform, but it’s usually 4 bytes. A: Using the ‘const’ keyword. A: Operators are symbols used to perform operations on variables and values. A: Unary operators work on a single operand, binary on
two, and ternary on three. A: “++i” is a pre-increment operator, while “i++"” is a post-increment operator. A: It’s a shorthand way of writing an if-else statement in a single line. A: It gives the remainder when one number is divided by another. A: It is used for conditional branching in a program. A: It is used for multi-way branching based on the value
of an expression. A: A loop is a control structure that allows you to execute a block of code repeatedly. A: “while” tests the condition before execution, “do-while” tests it after, and “for” has initialization, condition, and update expressions. A: A nested loop is a loop that is contained inside another loop. It is commonly used for iterating over multi-
dimensional arrays or for implementing complex patterns. A: You can use the “exit” function from the library to terminate the program at any point, providing an exit status code. A: The “break” statement is used to exit a loop or switch statement prematurely, while the “continue” statement is used to skip the current iteration of a loop and proceed to
the next iteration. A: The “goto” statement allows you to transfer control to a labeled statement within the same function. However, it is generally discouraged because it can lead to unreadable and unmaintainable code. Q: What is a function in C? A: A function is a block of code that performs a specific task. Q: What is the difference between a
function declaration and a function definition? A: A declaration tells the compiler about the function’s name and return type, while a definition provides the actual function implementation. Q: How do you pass parameters to a function in C? A: By defining function parameters in its parentheses. Q: What is recursion in C? A: Recursion is a technique
where a function calls itself to solve a problem. Q: Explain the difference between “call by value” and “call by reference.” A: In call by value, a copy of the argument is passed to the function, while in call by reference, the actual argument’s memory location is passed. A: An array is a collection of elements of the same data type stored in contiguous
memory locations. A: By using the array name followed by the index in square brackets. A: A pointer is a variable that stores the memory address of another variable. A: There’s no difference; both declare a pointer to an integer. A: A pointer that doesn’t point to any memory location is called a null pointer. A: A structure is a user-defined data type
that groups variables of different data types. A: By using the dot operator (.) A: A union is similar to a structure but shares memory among its members. A: In a structure, each member has its memory space, while in a union, all members share the same memory space. A: Structures are used when you need to store multiple pieces of data, and unions
are used when you want to save memory by sharing storage among different types. A: File handling is the process of reading from and writing to files using C. A: By using the fopen() function. A: By using the fclose() function. A: Text files contain human-readable text, while binary files store data in a format that is not human-readable. A: Using
functions like ‘fscanf()‘ or ‘fgets()’. A: Dynamic memory allocation allows you to allocate memory during program execution. A: By using functions like malloc(), calloc(), or realloc(). A: By using the free() function. A: Memory leak occurs when allocated memory is not deallocated, causing the program to consume more memory over time. A: malloc()
allocates uninitialized memory, while calloc() allocates zero-initialized memory. A: Preprocessor directives are commands that are processed by the preprocessor before actual compilation. A: It is used to include header files in the source code. A: It is used for creating macros and constants. A: Conditional compilation allows you to include or exclude
code based on preprocessor conditions. A: #ifdef checks if a macro is defined, and #ifndef checks if it’s not defined. For example, suppose you want to print the same words ten times. You can type ten printf functions, but it is more convenient to use a loop. All you need to do is to set up a loop that executes the same printf function ten times. We use
the concept of looping when we need to execute the same action several times. When we write the code, again and again, we have to use the loop body. In this article, we will discuss why loops are used in C programming? and category of loop with appropriate example and explanation. Table of Content “Looping” means repeating a task Looping is
the act of repeating a set of instructions.“Finite loops” refers to repeated executions of instructions in a certain number of iterations.Infinite loops refer to the continuous execution of instructions.This is the case with looping statements or iterations that execute repeatedly through a loop. Reduce the length of the code.You will save time.

Category of Loops in C Entry Control LoopExit Control Loop Entry Control Loop In the entry control loop, first, the condition will check then instructions or looping statements will execute.A for and while loop is an entry control loop. for Loop Most programming languages use the for loop, which is the most popular and most used loop structure.A for
loop is an efficient way to write a loop that repeats a specific number of times.When a for loop is used, it repeats a set of statements until a given condition is met.If the user knows how many iterations there have been, that is good. Syntax for(Initialization; Condition; Increment/Decrement) { Body of the loop; Iterations; }
TermDescriptionlInitializationThe initial value of the loop counter. Condition If you specify how many iterations the loop will run, then it determines how many times the loop will run. Increment / Decrement Amount of change in loop counter either increased or decreased (++, - -). Working of the For Loop Step 1: We execute the initialization step first,
only once.During this step, you can declare and initialize any loop control variables. Step 2: Afterward, we have the condition test.The loop executes if the condition is true, and if it is false, the body of the loop does not execute.And then the flow of control jumps to the next statement just after the ‘for’ loop. Step 3: Then loop statement is
execute.Depending on the loop counter or loop variable value, it will increase or decrease. Step 4: Then, the condition is tested again and the same process as in step 2 is run until the condition goes away. Program Print 1 to 10 Number #include #include void main() { int i; clrscr(); for(i=1; i



